Vmware-server 2.x on Slackware 13.0

Posted: February 26, 2010 in Linux

Tried to install vmware-server v2 on slackware 13.0 for hours to no success and then I found this patch and a script (to run the patch) which at first didn’t work for vmware server v2 (since it’s for vmware workstation 6.5.2),
but hey … I delete all uneeded lines (12 lines to be exact, from line 1 to 12), see below :

diff -urN source-OLD/vmblock-only/Makefile source-NEW/vmblock-only/Makefile
— source-OLD/vmblock-only/Makefile    2009-03-26 22:05:21.000000000 -0700
+++ source-NEW/vmblock-only/Makefile    2009-04-04 02:17:17.000000000 -0700
@@ -122,7 +122,7 @@

vm_check_build = $(shell if $(CC) $(KBUILD_CPPFLAGS) $(KBUILD_CFLAGS) \
$(CPPFLAGS) $(CFLAGS) $(CFLAGS_KERNEL) \
–    $(EXTRA_CFLAGS) -Iinclude2/asm/mach-default \
+    $(EXTRA_CFLAGS) -I$(HEADER_DIR) -Iinclude2/asm/mach-default \
-DKBUILD_BASENAME=\”$(DRIVER)\” \
-Werror -S -o /dev/null -xc $(1) \
> /dev/null 2>&1; then echo “$(2)”; else echo “$(3)”; fi)

(that’s the line that I DELETE), save the patch, run the the sh script and … voila .. it works!
Simply execute vmware-config.pl after that then I have vmware-server v2 in my slackware 13.0 machine.

(hint : if you want to try this don’t forget to install linux-pam package too)

Advertisements
Comments
  1. gugun says:

    nice solve…..

    Remember me????

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s